Skip to content

memfs version warning #881

Open
Open

Description

@alok1111

Current behavior

Warning appears

yarn install v1.22.22
[1/4] Resolving packages...
warning fork-ts-checker-webpack-plugin > memfs@3.6.0: this will be v4

Expected behavior

No warnings

Steps to reproduce the issue

Run yarn install in a project with webpack-dev-server@5.2.3 and fork-ts-checker-webpack-plugin dependencies

Issue reproduction repository

Environment

  • fork-ts-checker-webpack-plugin: 9.1.0
  • typescript: 5.5.4
  • eslint: 8.57.1
  • webpack: 5.104.1
  • os: Debian GNU/Linux 13

Activity

  1. caghand commented on Apr 20, 2026

    @caghand

    Yes, we are having the same issue... memfs v3 is no longer maintained, and is at risk of vulnerability discoveries that will not be addressed. It would be really appreciated if you could upgrade to memfs v4.

  2. fuleinist commented on May 27, 2026

    @fuleinist

    Note: this is addressed by #894 which upgrades memfs to ^4.0.0

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions